教你如何选择对应不同平台的PHP版本

很久没去PHP官网下载新的PHP了,每次重装系统后搭建PHP运行环境,不免要跑上来看看最新的WINDOWS平台下的版本,目前官方一共给了四个版本下载,V5.3的VC9 x86 Non Thread Safe、VC9 x86 Thread Safe,如下图:

以及V5.2版本的VC6 x86 Non Thread Safe、VC6 x86 Thread Safe,

如何选择呢,根据PHP官网下载页的左侧有个如何来选择版本的提示。

根据这个提示就知道选择何种版本来使用了。
下面就对选择依据作出详细解释。
一、如何选择PHP的VC9版本和VC6版本

VC6版本是使用Visual Studio 6编译器编译的,如果你的Web服务器是用Apache来架设的,那你就选择VC6版本。

VC9版本是使用Visual Studio 2008编译器编译的,如果你的Web服务器是用IIS来架设的,那你就选择VC9版本。

二、如何选择PHP的Thread Safe和Non Thread Safe版本

先从字面意思上理解,Thread Safe是线程安全,执行时会进行线程(Thread)安全检查,以防止有新要求就启动新线程的CGI执行方式而耗尽系统资源。Non Thread Safe是非线程安全,在执行时不进行线程(Thread)安全检查。

再来看PHP的两种执行方式:ISAPI和FastCGI。

ISAPI执行方式是以DLL动态库的形式使用,可以在被用户请求后执行,在处理完一个用户请求后不会马上消失,所以需要进行线程安全检查,这样来提高程序的执行效率,所以如果是以ISAPI来执行PHP,建议选择Thread Safe版本;

而FastCGI执行方式是以单一线程来执行操作,所以不需要进行线程的安全检查,除去线程安全检查的防护反而可以提高执行效率,所以,如果是以FastCGI来执行PHP,建议选择Non Thread Safe版本。

reeoo.com - web design inspiration

发表评论

电子邮件地址不会被公开。 必填项已用*标注